what happend ?

galagala(5)May 21, 2013

I have 15 Enterprise, which looked healthy in early spring. Gave them 10-10-10 in early march. Now 10 of them look like I may have to cut them down! They have that dead look, but still show a little green on the tips.Can't believe I gave them to much fertlizer! The other 300 got the same amount of fert? All responses appreciated!!! They have been in the ground for 4 years.

Thank you for reporting this comment. Undo
KG_in_CT

Is it possible they got hit by frost?

    Bookmark   May 21, 2013 at 2:00PM
Thank you for reporting this comment. Undo
fruitnut Z7 4500ft SW TX

You'd have a hard time killing 4 yr trees with fertilizer. I'd suspect something more like collar rot or some type root issue. If all the other trees are OK and 10 of one are dying it should either be the root, scion, or a really wet spot.

Has the spring been really wet?

My apples and pears were unfazed by 24F two weeks ago. Doubt it's spring freeze but could be winter cold, that should require -30 or -40F.

    Bookmark   May 21, 2013 at 3:52PM
Sign Up to comment
More Discussions
Grafting acocados
I am grafting an avocado tree. Is it alright to graft...
tim45z10
Is it just me or have my plum tree buds gotten bigger lately?
I have a bruce plum tree that i planted last september. It...
tlbean2004
Asian pear spray in first year
Just planted a dwarf asian pear from Starks. Do I need...
ferroplasm Zone 7b
Cherry tree damage from storm
Top third of cherry tree snapped off by falling limb...
jimfnc7
Too new to know...is this root acceptable?
I'm new to Orcharding and to GardenWeb (what an incredible...
GuardinDawg
© 2015 Houzz Inc. Houzz® The new way to design your home™