Strawberry Question

gltrap54May 23, 2012

Planted June bearing (Jewel) plants last fall & the plants look very nice but they've produced very few blooms. I've always had good luck with these plants in the past & don't know what might be wrong. Could excessive heat (ie 97 in March) and/or fertilizer be a factor?

Thank you for reporting this comment. Undo
gltrap54

Mmmm Kaaay............. Research indicates excess fertilizer..... Thanks for the input......

    Bookmark   May 24, 2012 at 8:07PM
Thank you for reporting this comment. Undo
ltilton

Excess nitrogen. Strawberries are heavy feeders, but the fruit-making needs more P, less N, which will give you lots of nice dark green leaves but not fruit.

I've seen 10-10-10 recommended for strawberries.

    Bookmark   May 24, 2012 at 8:10PM
Sign Up to comment
More Discussions
Raising Blackberries For Fun and Profit-Prime Jim
I stumbled across this video on Prime Jim blackberries....
2010champsbcs
Looks like no pears this year.
We have gotten a lot of chill hours this year for the...
insteng
Bareroot pruning of a multi-branched nectarine?
Just picked up a bareroot Snow Queen and it has several...
brownmola
Too new to know...is this root acceptable?
I'm new to Orcharding and to GardenWeb (what an incredible...
GuardinDawg
Is it just me or have my plum tree buds gotten bigger lately?
I have a bruce plum tree that i planted last september. It...
tlbean2004
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™