My orchid is worrying me (not blooming, yellow leaves)

polliceverdeJanuary 13, 2014

I bought this orchid phalaenopsis early last month, with two stems, three flowers and three buds. A couple of days later, it started dropping the flowers and the buds (a bud blast?) - I thought it was lack of light or due to close proximity to other plants. It was only till it dropped all the buds and flowers that I moved it to a location in which there was much more light (which is like a greenhouse). Now a leaf at the lower part of the plant turned completely yellow. Just for your info, mine is a meditarranean climate, which in January has an average temperature of 13 degrees celsius (56 fahrenheits). Attached is an image of the plant, would be really glad if you could help me out!

I have some more images if you think that the below image is not sufficient.

Thank you for reporting this comment. Undo
arthurm(Sydney, NSW AUST)

This conversations page is not the place to ask orchid culture questions. Much more activity over on the discussions page including many discussions about problems with Phalaenopsis.

    Bookmark   January 13, 2014 at 10:24PM
Sign Up to comment
More Discussions
It is show time!
Show season is in full swing. In my area I have noticed...
Darlene (GreenCurls)
Brassavola "Little stars" vendor
Any suggestions for US vendors? A Google search found...
bea
my phalenopsis has a baby orchid on the stem
what do i do? I've never seen this before
ekkiemom
Is this a spike?
I know what Phal spikes look like, but am new to these......
suzabanana (6b Boston)
stanhopea
I'd like to try growing the stanhopea orchid. do you...
greendale63
© 2015 Houzz Inc. Houzz® The new way to design your home™