Brown Alge

moregirll8000August 19, 2005

Here are the pics of the tank with the alge problem. Hope this helps!

Image link:

Thank you for reporting this comment. Undo
birdinthepalm

Sorry , but I think you'd need to use a closeup or macro image to give a better idea of the problem. I don't have the best eyesight , so maybe I'm missing something most folks could see in the picture?

    Bookmark   November 13, 2005 at 7:49AM
Thank you for reporting this comment. Undo
beumae680(Z5 Tn.)

Hi, I have the same problem, if you find out what is causing this and what to do to correct it please e-mail me. Need help too.chandler_37303@msn.com

    Bookmark   April 27, 2006 at 10:19PM
Thank you for reporting this comment. Undo
fishman101

phosphate get a phosphate remover or just try cutting down on the light. ( if you have your lights on 10hrs a day try 6hrs) this will also help

    Bookmark   March 30, 2008 at 10:04PM
Sign Up to comment
More Discussions
Stupid Walmart, i want to cry
I hate my walmart even more now than i did before....
Cheart99
My Aquascape 375 round fronted tank
I have done several 5ft Aquascapes but this was the...
keithgh
Blackmoor changing colors
One of my blackmoors has been developing the most unusual...
asleep_in_the_garden
guppies....why cant i keep them?
greetings: I have had several fish tanks since i was...
missa
Weird Betta Behavior
Hey y'all. I have a question about my betta. He has...
tighebettalover
© 2015 Houzz Inc. Houzz® The new way to design your home™