colocasia esculenta blooms "Black Beauty"

jardinerowaJanuary 13, 2014

Hey all!

Early last year I got a small start from an online nursery and planted it. By the summer it had grown nicely with several offsets. By the late fall, it started to produce blooms with yellow spathes. The problem is that when the bloom got big enough to where you would think the spathe would open a bit, it would just wither and die. This happened on both blooms. I can't tell if I saw all there was to the bloom or if there was a problem. Thanks!

Z

Thank you for reporting this comment. Undo
Tiffany, purpleinopp GardenWeb, Z8b Opp, AL(8B AL)

Did it look like this one (on plain green C. esculenta?) This is about all this does. Then withers after a few days. Easy to miss!

    Bookmark   January 17, 2014 at 9:00AM
Thank you for reporting this comment. Undo
jardinerowa

Yes that looks very close! Although I didn't notice the opening that showed the spadix. Of course I didn't look all that hard. Thank you!

Z

    Bookmark   January 24, 2014 at 9:11PM
Sign Up to comment
More Discussions
Can an albino Amorphophallus titanum survive?
One of my a titanum seedlings is completely white,...
stevelau1911
Amorphophallus galbra
Rob, There's a maximum of 150 posts on a thread and...
tropicbreezent
Aglaonema
Anyone know the name of this Aglaonema hybrid? Only...
russ_fla
Anyone growing Philodendron pedatum?
I just recently purchased a juvenile Philodendron pedatum. It...
summersunlight
New Amorphophallus seedlings for 2015
I just planted a batch of a titanum seedlings about...
stevelau1911
© 2015 Houzz Inc. Houzz® The new way to design your home™