What is wrong with my rhodos? Photo Link

mayfirst(S Van Island)April 21, 2007

Hi,

I have two beautiful rhodos blooming now (one is Unique and the other I forget) but both of them have ugly black spots on some, not all, of the flowers. They are established plants and I don't remember ever seeing this problem in the past. I've posted a link below to my two photos- and I think if you click on the photos they will enlarge.

Can anyone identify the problem and provide a solution? Thanks!

http://homeswaps.googlepages.com/plants

Thank you for reporting this comment. Undo
morz8(Washington Coast Z8b)

Mayfirst, that looks like petal blight.

Caused by a fungus, the disease develops during periods of moist weather at flowering time. You'll want to practice good sanitation and remove any spent flowers, litter under your plants. Spraying buds with fungicide (Bayleton recommended) just as they begin to show color but before they open is a good means of control...since you've had petal blight in your garden this season, you might want to consider treating your rhododendrons early next year.

    Bookmark   April 22, 2007 at 11:56AM
Thank you for reporting this comment. Undo
mayfirst(S Van Island)

Thank you very much. It sounds serious. Is it too late to do anything this year? I would hate to loose these beauties!

    Bookmark   April 23, 2007 at 11:52AM
Thank you for reporting this comment. Undo
luis_pr

Hello, mayfirst. Sorry but, no amount of spraying will cure this year's infestation. However, after all of the flowers have dropped, practice the sanitation techniques that morz8 recommended. Then, next year, begin a fungicide application routine just as the buds begin to swell and show a little color. Spray up to bloom time.

Good luck,
Luis

    Bookmark   April 27, 2007 at 2:20AM
Sign Up to comment
More Discussions
Best rhoderdendron for my area zone 7b Ga.
Looking for a 4ft red,pink or white with a long bluming...
420benz
floral azelea question
I just got an azelea from a grocery and it looks like...
fievel38
azalea few yellow leaves
I'm having a problem with some of my azaleas. Their...
trees_in_winter
Can anyone identify?
Hi these are two azaleas that we have had here since...
hello459
thoughts on permanent soil enhancement
This is more or less a followup to Mainegrower's questioning...
davidrt28 (zone 7)
© 2015 Houzz Inc. Houzz® The new way to design your home™