Azaleas are DYING!! :(

SSGarden(6a)June 5, 2013

I recently purchased an Azalea from Home Depot. I live in Toronto, so I repotted it, instead of planting in the ground. I planted it in Peat Moss, but my Azalea leaves are just dropping and dropping. The buds are turning crispy brown, and they aren't blooming. What do I do? I don't want them to die.

Thank you for reporting this comment. Undo
akamainegrower

Pure peat moss, especially as a potting medium, causes many problems. It tends to be either too wet which deprives the plant roots of oxygen or too dry making rewetting very difficult. It also contains 0 nutrients and, if you're using the peat moss dust sold in bales just about everywhere, it's too fine and easily compacted.

Repot into a planting medium that contains perlite, bark, or other bulk material in addition to peat. Chances are it will put out new growth even if it has lost most of what t had when you bought it.

    Bookmark   June 6, 2013 at 6:07AM
Thank you for reporting this comment. Undo
rhodyman(SE PA, USDA Z6)

Be sure to open up the roots and soak for an hour when replanting. Make sure the pot and the mix are very well drained. Only water when the pot feels light. Don't over water.

Here is a link that might be useful: How To Plant (Rarefind Nursery)

    Bookmark   June 9, 2013 at 6:09PM
Sign Up to comment
More Discussions
Do any Encore Azaleas attract hummers?
I may be having some azaleas replaced with dwarf, due...
Bama_Joe
Can anyone identify?
Hi these are two azaleas that we have had here since...
hello459
floral azelea question
I just got an azelea from a grocery and it looks like...
fievel38
Anybody out there have luck with Rhodos in Southern Arkansas?
Looking for any feedback from Houzz readers who have...
Rusty Empire
Please help to ID those two Rhodos
I found two interesting Rhodos (one elepidote, one...
rockimea
© 2015 Houzz Inc. Houzz® The new way to design your home™