Encore Azalea Leaf Problem

lafu115(7)August 7, 2010

I planted some Encore Azalea in May. They are growing well but the last two to three weeks have developed discolored leaves. Photos attached. What could be causing this? Thanks!

/Users/LTM/Pictures/iPhoto Library/Modified/2010/Aug 6, 2010/IMG_0471.JPG

/Users/LTM/Pictures/iPhoto Library/Modified/2010/Aug 6, 2010/IMG_0473.JPG

/Users/LTM/Pictures/iPhoto Library/Modified/2010/Aug 6, 2010/IMG_0472.JPG

/Users/LTM/Pictures/iPhoto Library/Modified/2010/Aug 6, 2010/IMG_0474.JPG

Thank you for reporting this comment. Undo
rhizo_1 (North AL) zone 7

The images did not upload correctly.

    Bookmark   August 9, 2010 at 9:53AM
Thank you for reporting this comment. Undo
lafu115(7)

I can't figure out how to upload pictures! Hopefully this link will work:

http://picasaweb.google.com/lh/sredir?uname=lafu115&target=ALBUM&id=5503962355966532129&authkey=Gv1sRgCMiOkcm4yub5Ig&feat=email

    Bookmark   August 10, 2010 at 9:52PM
Thank you for reporting this comment. Undo
jean001(z8aPortland, OR)

Looks like the rootball is short of water. Sick a finger into the *original* rootball to find out.

    Bookmark   August 10, 2010 at 10:30PM
Sign Up to comment
More Discussions
Please help me identify this azalea
When I purchase my house, it had a beautiful azalea...
mmp01
Spring is here.....
=================== 'nuff said! ===================...
Emerogork2
Do any Encore Azaleas attract hummers?
I may be having some azaleas replaced with dwarf, due...
Bama_Joe
Azaleas dying
Hello. We are having a problem with some newly planted...
westminstress
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™