Mouldy Guzmania blooms

phee78March 3, 2013

I recently got a Guzmania, don't know its exact name, but it's got an orangey red inflorescence. I just noticed that the little buds at the top of the inflorescence are covered in mould. Pulling back some of the bracts further down, I noticed a bit of mould in there too.

It's not the usual dying off of a brom flower, it's like when a loaf of bread goes mouldy and you get furry stuff growing on it. Anyone ever experienced this before, or have any idea what I could do to fix it?

This post was edited by phee78 on Sun, Mar 3, 13 at 2:05

Thank you for reporting this comment. Undo
jwnesmith(8b/9)

I have found this with my Aechmeas. It seems to be the flower and so far has not gotten into the berry. We'll see. It probably comes from the humidity level.

    Bookmark   March 3, 2013 at 12:45PM
Thank you for reporting this comment. Undo
hotdiggetydam

air circulation is to low

    Bookmark   March 8, 2013 at 1:56AM
Sign Up to comment
More Discussions
ID Please
Another one I lost the tag to,can you please help me...
gardencraze
id help- tillandsia exserta hybrid?
I traded a friend of mine for this.Its original tag...
Brian311
ID help for a couple of things at Harry P. Leu Gardens in Orlando
I was at Leu Gardens earlier this week and, among a...
gdadtravelinig
Impulsiv-ity and Tillandsia
Good Morning! Newbie here (to all plants). In an extremely...
Kristinkle
seeking info on Neo Royal Flush
A web search gives me a wide range of conflicting information...
pearlbegonia
© 2015 Houzz Inc. Houzz® The new way to design your home™