Trouble with my coreopsis 'Sienna Sunset'

Nathy LavoieAugust 10, 2013

I purchased some coreopsis 'Sienna Sunset,' my favorite! They were in bloom at the time (1st pic). I planted them in garden soil and the blooms lasted about 2 weeks. I was deadheading them as the blooms died. Now the new buds won't open even after waiting weeks (the last pic). I wonder why. Anyone knows what I could do?

All Photos are copyright Natalie Lavoie 2013 and may not be used in any form without my permission.

This post was edited by Blackdesertwind on Sat, Aug 10, 13 at 15:04

Thank you for reporting this comment. Undo
Nathy Lavoie

Here are the buds that won't bloom.

    Bookmark   August 10, 2013 at 1:30PM
Thank you for reporting this comment. Undo
ianna(Z5b)

It's just takes a little more time bloom. I can see these buds still have some maturing to go.

    Bookmark   August 12, 2013 at 11:09AM
Thank you for reporting this comment. Undo
Nathy Lavoie

The buds don't seem to be maturing though after all that time.

    Bookmark   August 12, 2013 at 8:35PM
Thank you for reporting this comment. Undo
ianna(Z5b)

could be what's called bud balling. It's unclear exactly what causes that problem but cool wet weather is one of the reasons. Just water in the evening and not during hot sunny days. I would suggest fertilizing but that's not what you should do in the height of the summer sun....

All you can do is be patient and hope it improves.

    Bookmark   August 13, 2013 at 3:05PM
Thank you for reporting this comment. Undo
Nathy Lavoie

These were planted in a new flower bed so the soil is fertile enough and I water only as needed early in the morning and late in the evening when needed.
They are not soaked but did not dry out either.
I never water in mid day except for potted plants.

    Bookmark   August 13, 2013 at 3:17PM
Thank you for reporting this comment. Undo
ontnative(5b Can/USDA 4)

Are they in full sun? I have problems with a few of my coreopsis cultivars not opening or not blooming enough, but I think in my case, it is not enough sun.

    Bookmark   August 18, 2013 at 8:23AM
Thank you for reporting this comment. Undo
Nathy Lavoie

Yes they are in full sun...as of today those buds still did not bloom :(

    Bookmark   August 18, 2013 at 2:37PM
Thank you for reporting this comment. Undo
ianna(Z5b)

Its probably more to do with having been transplanted that stunted growth for now... Just be patient.. it may not bloom at all this season but it will by next season.. Keep the roots healthy. These things happen.

    Bookmark   August 19, 2013 at 11:23AM
Sign Up to comment
More Discussions
Weeping Mulberry
My fruiting weeping mulberry cracked at the head, presumably...
gastonal
weed or no weed?
approx 4 ft tall any info appreciated
ralu25
overseeding a lawn in vancouver
Hi all, My front yard is... a mess. The house is new...
dalans
Canadian Garden blogs
I would love to collect a list of Canadian garden blogs...
Crafty Gardener
hardy annuals
hey all i live on vancouver island, just wondering...
tomlinson04
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™