'Cherry Bells' aren't blooming! :(

daphnelogue(7 Peidmont NC)July 17, 2008

I have two masses of Bellflower "Cherry bells" that I originally planted early last spring from containers bought at a local nursery. They were full of flower blooms last year- and they actually bloomed the entire summer. This year, when they started coming back, they started spreading out and making themselves at home. They aren't "invasive" because I like where they are. However, there is only ONE bloom on each set! :( What's going on?

Any ideas????

Thanks a million!

Daph

In the RDU area

Thank you for reporting this comment. Undo
Dibbit(z7b SC)

Have you fed them, and if so with what? If they got any run-off from lawn fertilizer, they got too much nitrogen, and duly grew leaves. They need a fertilizer with a low first number, since flowers and roots grow with the encouragement of phosphorous - the second numbers on a label. My Callibrachoa/Million bells also came back from last summer, and are also being less floriferous than they were, so I am stepping up my feeding of them.

    Bookmark   July 17, 2008 at 5:17PM
Sign Up to comment
More Discussions
Indoor planting?
Hi, Did anyone start indoor vegetable seeds sowing?...
aaaaaaaa
Central Carolina Chrysanthemum Society
The Central Carolina Chrysanthemum Society will have...
hosta200
Copper Canyon Daisy
Does anyone know where i can find seed or plants of...
Ralph Whisnant
Agave victoria-reginae hardiness
Hi, Has anyone successfully grown these outside in...
seedmoney
Fruit trees
Hi! We've decided we have room for nine more fruit...
HollowOakFarm
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™