Princess Diana

redsox_gwJuly 19, 2010

I bought this as a tiny baby from Bluestone a couple of years ago and planted it in the Fall of 09. This year it produced ONE flower. The vines have grown well enough but not produced. Is this clematis slow to get started or did I pick a bad spot? It gets very full sun.

Thank you for reporting this comment. Undo
jeanne_texas(Z 8B TX)

Mine Grew like a weed after a couple of years..remember sleep, creep and then leap..mine gets about 8 hours sun and next to a sprinkler head...Jeanne

    Bookmark   July 19, 2010 at 5:19PM
Thank you for reporting this comment. Undo
dublinbay z6 (KS)

Mine was slow to bloom also, and still does not bloom very heavily (it's about 5 years old). And mine is in full sun also. I'm getting the impression that it needs more frequent watering than my other clems. Unfortunately, I forget sometimes--but it perks up quickly when I finally remember and rush out with the spray hose.

Cutest little pink trumpets!

Kate

    Bookmark   July 20, 2010 at 3:46AM
Sign Up to comment
More Discussions
Clematis heaving out of the ground?
Hi. I have a 4 year old Jackmanii clem that has begun...
lismari
Clematis Princess Kate
Hmm, a new Texensis, looks pretty spiffy. Let's see...
boday
Is this clematis 'dead legs'?
Hello, I'm new to this site and growing clematis I...
marko_212
Need advice/insight on my Clematis
I'm in Zone 5/6, Pennsylvania. So I bought this Clematis...
lady_alicia Zone 5/6 PA
Clematis Question?
I am just giving my clematis (Guernsey Cream) a very...
gardenbug
© 2015 Houzz Inc. Houzz® The new way to design your home™