Jackmanii all leaves, few flowers

maureen1953(Z4 Central NY)July 17, 2009

I have a humongous 15 yr old Jackmanii that has healthy vines and leaves but very few flowers. I spread wood ashes around the base of it (we have acid soil) this spring, and some organic tomato fertilizer...too much nitrogen, or what are your thoughts...thanks!

Maureen

Thank you for reporting this comment. Undo
buyorsell888(Zone 8 Portland OR)

Tomato fertilizer should have high phosphorus than nitrogen and there is no need for the wood ashes so they should not affect bloom. Acid soil is fine.

Do you hard prune it every year? Jackmanii blooms on new growth.

Has the amount of sun it gets changed?

    Bookmark   July 19, 2009 at 2:14PM
Thank you for reporting this comment. Undo
maureen1953(Z4 Central NY)

I prune it down to about 6 inches in early spring. I'll stop the wood ashes...don't know what else the problem would be. It's in full sun, roots shaded.

    Bookmark   July 24, 2009 at 10:03PM
Thank you for reporting this comment. Undo
buyorsell888(Zone 8 Portland OR)

Try a bloom booster type fertilizer.

    Bookmark   July 25, 2009 at 10:54PM
Sign Up to comment
More Discussions
Plans for 2015
This forum has been quiet for so long... so maybe it'll...
Michaela .:. thegarden@902 .:. (Zone 5b - Iowa)
transplanting ?
My friend is getting rid of (throwing away) a clem...
sorie6
Aack! Clay soil!
Late one night in throes of my new clematis obsession,...
cohouser
Snowy winter and first-time clematis - advice please
Last fall I planted my first clematis and we've been...
vesfl
Is Sweet Autumn Clematis Appropriate?
My neighbors utility vehicles are parked right up to...
florananny
© 2015 Houzz Inc. Houzz® The new way to design your home™