zinnia problems

upson22July 31, 2008

My zinnias this year are green, had plenty of rain here in Michigan, I've used a fungicide,it's been pretty wet,and have used sevin once,(japanese beatles)I fertilize with fish emulsion. Here's my problem,I first noticed stems with nice big buds bending at the top, stems seem soft, and very few flowers. Nothing had changed much from last year except I did replant in the same place. The plants look healthy. just lots of bent over stems and few blooms.

Any ideas?

Thank you for reporting this comment. Undo
bfff_tx(z8b TX)

Sounds like the plants are possibly getting too much nitrogen. How often are you giving them the Fish Emulsion and how much of it. I'd be inclined if they have healthy growth to fertilise them with a super bloom (phosphate) fertilizer. Make sure the 2nd no. is in the 50's and the 1st no. (nitrogen) is below 5 (if possible).
Cheers - Kim
Billabong Fresh Flower Farm

    Bookmark   August 3, 2008 at 11:05PM
Thank you for reporting this comment. Undo
upson22

Thanks for your advice, I'll give it a try, I've only fertilized with the fish emulsion twice, I used 2 quarts in 2 100' rows.

    Bookmark   August 6, 2008 at 8:22AM
Sign Up to comment
More Discussions
Please recommend cut flowers
I have two spots open in my raised bed for two plants....
mshelenlu
High temps reducing cuts?
I am in my second year of growing cut flowers for farmers'...
Mike_PP11
Bright Light Cosmos Never Again
This is the second year in a row that my bright light...
weld
White flowers for dappled shade
Looking for white annuals or perennials for under the...
lmsparkie
Cutting Zinnia's to vase
I have a few basic questions that I could not find...
Lady9
© 2015 Houzz Inc. Houzz® The new way to design your home™