jasmine sambac (single petal)blooms issue

kandhi(z7VA)August 25, 2011

I have noticed that regular jasmine sambac plants when planted in 5-1-1 mix do not bloom well for me. The moment I plant them in this mix, the plant grows well with lot of green and forms buds but they either shriwel up or turn red in bud phase and die. It is currently happening with 2 of my plants. There is another jasmine sambac in miraclegro soil compact soil that is doing fine where the buds grow and bloom. This is so strange as my other jasmines like grandduke, nitidum and molle love 5-1-1 soil mix and do bloom good under same climatic conditions. Did anyone notice similar behavior with ther regular jasmine sambac if you happen to use 5-1-1 mix for your tropicals?

Thank you for reporting this comment. Undo
Robert (zone 7a, Oklahoma)

Hi kandhi!

I have a huge Maid of Orleans growing in the 5:1:1 mix. It's doing great and blooming profusely (as is my Belle of India and Jasminum molle also in the 5:1:1 mix).
I'm assuming you're keeping it well watered and fed?
I wonder if it could be an insect or disease issue?

Good luck!

-Robert

    Bookmark   August 25, 2011 at 3:53PM
Sign Up to comment
More Discussions
Osmanthus fragrans 'Fudingzhu'
I bought three large plants because I read about their...
KJMM
What is the Best Way to Ship Gardenia?
Since gardenia is so hard to be kept alive, I just...
redsun9
Fragrant book reviews!
I was all in love with my latest fragrant book that...
Robert (zone 7a, Oklahoma)
Jasmine sambac 'MOO' growth habit
I've seen other posts about the scrufulous habit of...
dbarron
Ixora odorata
Hello, does anyone have this on the mainland U.S.A.?...
donnagoetz
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™