Chrysanthemums and some problems...

Bumblebeez SC Zone 7August 28, 2009

I bought two large perennial mums for my screened in porch several weeks ago.

A lot of the buds turned brown and sort of dried up. The leaves themselves are fine- a few brown leaves at the base that I picked off and a few dead stems. I deadheaded it well today.

I bought the mums in a tight bud state hoping they would last a long time.

They were in bright shade.

I just bought another one and hope to have it last longer.

Did I overwater (probably not) underwater or is it a disease?

How can I make my new one bloom well?

Thank you for reporting this comment. Undo
Bumblebeez SC Zone 7

Ok, well, I'll just keep it extremely well watered.

    Bookmark   August 31, 2009 at 1:10PM
Thank you for reporting this comment. Undo
girlgroupgirl(8 ATL)

Sorry, this is a problem we had when I worked at a nursery too. What I found is that they are growing the mums under misters and they plant them in 99% peat moss. The roots really fill those pots, and it is hard to keep them perfectly moist without having them soppingly and rottingly wet, or dry as a bone.

    Bookmark   August 31, 2009 at 9:45PM
Thank you for reporting this comment. Undo
Bumblebeez SC Zone 7

Interesting and I'm glad it's not me. Thanks for the info.
I'll really have to put a lot more effort into watering them.

    Bookmark   August 31, 2009 at 10:03PM
Sign Up to comment
More Discussions
Shade Garden Ideas Help
I am renting a townhouse that has a 4X4 foot square...
jerseygarden123
Insured Tree Removal Cmp recommendations
Is there a good INSURED & reasonable tree removal...
vnginger
have: lime tree - free to good home!
I have an unknown type of lime tree (not a dwarf) planted...
alison234
winter veggies in straw bale garden?
I have used the straw bale gardening method in spots...
katy_bug
Howdy Folks!
Any of the old regulars still around? I have been...
vroomp
© 2015 Houzz Inc. Houzz® The new way to design your home™