helleborus not flowering

creeMay 11, 2006

I first purchased my helleborus hybridus last year sometime during the summer and it had flowers at the time. I planted it in a pot outside (due to living in an apartment) and it over-wintered wonderfully. I was very excited to see new leaves coming up in March but that's all that happened. The leaves look happy and healthy, but there are no flowers. Did something go wrong???

Thank you for reporting this comment. Undo
jgwoodard(USDA z7 TN)

Hello cree,

First, what kind of hellebore is it? If the plant is healthy overall I wouldn't worry. It's possible that it was grown in ideal conditions before you purchased it and 'got ahead of itself'. What size pot did you use, and what sort of media/fertilizer? The other major factor (and maybe the primary factor) is how much light it gets. If it is getting mostly shade then that could be the problem. The more light it gets in late spring-summer, the more blooms it will have later. Growing long term in pots can be a bit challenging with some hellebores.

Joseph

    Bookmark   May 23, 2006 at 8:42PM
Sign Up to comment
More Discussions
hybridizing, pushing pollin
is anyone crossing? i will be in about four weeks. hellebores...
bruce03451
Do Double Hellebores Flowers Droop?
Anyone with experience growing double hellebores? I...
KarenPA_6b
H 'Penny's Pink'
Does anyone have or know anything about this one?
shadeyplace
no flowers
I moved and split a hellebore 3 years ago, since then...
mayslass
New Transplants
Hi, I recently planted a couple of Hellebores in my...
mavarin
© 2015 Houzz Inc. Houzz® The new way to design your home™