Annabelle buds and leaf spots

lalalaJune 3, 2009

My newly-planted Annabelles have flower buds all over them. The buds look fuzzy, almost like they're covered by fine white cobwebs or mold, and I'm not sure if that is normal or a sign of something bad. Also, some leaves have small brown speckles on them--I assume a mild case of some kind of leaf spot. Anything to be concerned about? Pictures below. Thanks very much in advance!

Thank you for reporting this comment. Undo
jean001(z8aPortland, OR)

The small brown spots indicate a brief water shortage.

    Bookmark   June 4, 2009 at 1:01AM
Thank you for reporting this comment. Undo
lalala

Thanks! Can any Annabelle growers tell me if my flower buds look normal?

    Bookmark   June 5, 2009 at 9:37AM
Thank you for reporting this comment. Undo
hokierustywilliamsbu

look fine--will out grow that stage-mine are now in full bloom

    Bookmark   June 5, 2009 at 10:44PM
Thank you for reporting this comment. Undo
lalala

Great. Thank you!

    Bookmark   June 8, 2009 at 8:50AM
Sign Up to comment
More Discussions
Propogating Hydrangea
Hi, My neighbors have just put up a 6 foot high fence...
Jon
New 2015 hydrangea cultivars?
Anybody looking into what's coming in 2015. I thought...
plumism
galls in dirt where to plant
Hi, Last summer I dug up a rose that had not been doing...
Brooks23
So Cal Hydrangeas growth is stunt
Hi, I live about 3 miles from the beach in Southern...
nikole220
Endless Summer Hydrangea Wont Bloom
Hi. I have 2 Endless Summer Hydrangea's. This is the...
emba129
© 2015 Houzz Inc. Houzz® The new way to design your home™