Annabelle buds and leaf spots

lalalaJune 3, 2009

My newly-planted Annabelles have flower buds all over them. The buds look fuzzy, almost like they're covered by fine white cobwebs or mold, and I'm not sure if that is normal or a sign of something bad. Also, some leaves have small brown speckles on them--I assume a mild case of some kind of leaf spot. Anything to be concerned about? Pictures below. Thanks very much in advance!

Thank you for reporting this comment. Undo
jean001(z8aPortland, OR)

The small brown spots indicate a brief water shortage.

    Bookmark   June 4, 2009 at 1:01AM
Thank you for reporting this comment. Undo
lalala

Thanks! Can any Annabelle growers tell me if my flower buds look normal?

    Bookmark   June 5, 2009 at 9:37AM
Thank you for reporting this comment. Undo
hokierustywilliamsbu

look fine--will out grow that stage-mine are now in full bloom

    Bookmark   June 5, 2009 at 10:44PM
Thank you for reporting this comment. Undo
lalala

Great. Thank you!

    Bookmark   June 8, 2009 at 8:50AM
Sign Up to comment
More Discussions
Need help with hydrangea companions
Hello. I am putting in a new bed this Spring. It is...
suz9601
Hydrangeas in wet soil
I have an empty area beside our air conditioning unit...
ryank817
New 2015 hydrangea cultivars?
Anybody looking into what's coming in 2015. I thought...
plumism
Invincibelle� Spirit II Hydrangea arborescens
Does anyone know if the new Invincebelle Spirit Hydrangeas...
teri55
DEEP blue
When I was growing up my grandmother had big vigorous...
Kristin
© 2015 Houzz Inc. Houzz® The new way to design your home™