Filtration issues

yuhaftarunAugust 28, 2011

I have a waterfall bio-filter, a sweeper filter, and a Sequence pump. I also have a chemical filter on the water hose to rid all of the city added chemicals when filling the pond. All have been working perfectly since 2000 when I built the pond. I am down to 38 koi due to a pesky Great Blue Heron, and the pond is less than a quarter full of lillies. I clean my bio-filter once a year and I used to clean my sweeper filter once a week, whether it needed it or not. The sun has been tremendous this year. I have been using Algaefix according to direction, which has worked great in the past. This year I have added Microbelift to my pond. The cleaning of my sweeper filter has become intense this year. I have it down to a science now. I clean the damned thing EVERY EIGHT HOURS NOW! I need help, please.

Thank you for reporting this comment. Undo
jennie_in_mt(z3 MT)

What are you getting out of it? String algae?

    Bookmark   September 11, 2011 at 5:04AM
Sign Up to comment
More Discussions
Pond not deep enough
I purchased a house that has a small pond in front....
jennyzone5
Koi Pond Liners
I have been seriously pondering the design of a Koi...
flponder
winter 3000 gallon pond deicer / pond pump UNDER 2x4 wood frame
can i put a deicer and pond breather under a 2x4 wood...
WinterPondZone5a
Having issues controlling PH in a small pond
I've got a small pond (150gal) with 8x 4-5 inch koi...
Newguy27
New to koi
Hi folks, I just picked up an established koi pond...
james_vagabond
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™