Mona Lisa won't bloom

woodyswife(z5 OH)July 12, 2008

I've got 2 Mona Lisa lilies in one of my flower beds that I put in three years ago which have failed to ever bloom. The foilage comes up every year and looks healthy, but no flowers. I don't have this problem with any of my other lilies which are asiatic and oriental. I'm going to move these to another location and use some bone meal or possibly some fertilizer and see what happens. Does anyone have any other suggestions? Thanks

Thank you for reporting this comment. Undo
hld6(z7 MD)

We need more info. to help you. Are these planted in heavy shade?. How thick is the stalk? (I.e., is it possible these are immature bulbs?) Do you have buds that fail to open or do you not get buds at all? Fertilizer should not be the problem lilies aren't so fussy that it would keep them from blooming.

If you move them look at the size of the bulb. That is the most obvious reason for a lily not to bloom. Dried up "aborted" buds would indicate some type of stress.

-Helen

    Bookmark   July 12, 2008 at 9:26PM
Sign Up to comment
More Discussions
Best/Favorite Co. to get Lily Bulbs?
I would like to add some tall fragrant oriental, chinese...
aunt_lou
strange baby foliage
Message: I am new to planting lily. Last December I...
Rosidah
Take that voles/mice !
My lilies were looking beautiful & increasing for...
pandora
What the heck happened to my hybrid lilies
I brought this pot of lilies at home depot and it was...
tlbean2004
Red Lily Leaf Beetle Sited
11:15 am in Malden, Ma ( just outside Boston) Came...
MichaelB_MAz6
© 2015 Houzz Inc. Houzz® The new way to design your home™