having tomatoe problems

donnyl(7)May 24, 2014

Need help identifying a problem I am having with my tomatoes. Last week this was on just one plant. today it is on all of them and the first one is almost dead. I have sprayed with liquid sevin but I think it may be fungal or bacterial. any suggestions and solutions would be greatly appreciated.

this is my second year of square foot gardening. The original beds were made with mostly store bought materials. This year I expanded my bed using a lot of compost made from oak leaves, grass and vegetable scraps from the kitchen. Plants are in a 4 foot by 8 foot area in a checkerboard pattern. We have had a good bit of rain over the last two weeks.
thanks

Thank you for reporting this comment. Undo
donnyl(7)

another picture

    Bookmark   May 24, 2014 at 7:44PM
Thank you for reporting this comment. Undo
slowjane CA/ Sunset 21

It's some kind of leaf spot / blight. Likely fungal. Spray with an appropriate anti-fungal to see if you can control it. The rain probably is what did it - are they getting enough sun?

More advice at the link below...
You might want to search over in the Growing Tomatoes forum - they are the experts! Good luck!!

Here is a link that might be useful: Blight and Leaf Spot

    Bookmark   May 26, 2014 at 1:17PM
Sign Up to comment
More Discussions
Mighty Matos / Mighty Veggies and SFG
Does anyone here have experience with SFG and Mighty...
tafountain
Watery soil under raised bed
Hey all, I am new to raised beds, just started construction...
jazz1234
I'd like to try SFG like this....(see pic)
I'd like to try SFG in a 55 gallon drum like the one...
farmless_barn
Vining plants and selection for beginner.
So glad to have found this resource! I am starting...
GreenFox
staining wood for raised beds.
I'm wanting to build a raised bed and first went out...
johnmcd348
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™