Have no idea what this is...Please help!

Chelsea_2016(7b)June 12, 2013

Hi all,
New here and just build 3 raised beds and planted a lone tomato transplant 1 or 2 weeks ago. It looked all right until I started to notice some brown on the leaves. I've been searching the internet to figure out what it is, but I can't find anything.
Anyone know what this is? It seems to be spreading to more leaves and worsening.

Thank you for reporting this comment. Undo
Chelsea_2016(7b)

Sent this question to Bonnie's 'Ask the Expert' and they said it looks like fertilizer burn. I highly recommed asking over there as they will reply within 24 - 48 hours...

    Bookmark   June 14, 2013 at 7:10PM
Thank you for reporting this comment. Undo
jean001a(Portland OR 7b)

So how did they figure that out with the minimal amount of info you gave us?

And did you fertilize? If so, with what? and when? and how often?

Or does the bed have lots of manure in it?

Inquiring minds would like to know.

    Bookmark   June 15, 2013 at 12:04AM
Sign Up to comment
More Discussions
Help Identify my Uncle's Tomato pest
Hi all, I'm writing in behalf of my uncle who is not...
greengorilla2
worst tomato plants ever
Hi I have been growing tomato plants for at least twenty...
greelygarden
Tomato Leaf curl
I'm having problems with my Beefsteak tomatoes. The...
DoctorAche
Help Pls! Tomato branches falling off
Hi all - A few weeks ago I started to notice a marginal...
jhamoud
New Forum Sucks
Why is it when you have something great someone comes...
hoosier318
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™