What's wrong with my elepant ears

wrench75May 23, 2007

In Early March I bought 14 mammoth elephant ear bulbs from Wal-mart and put them in the ground. I planted them blunt side down about 1.5-2" under the soil. I've kept them wet, but I haven't seen any signs of life yet. What am I doing worng? Or am I just being impatient?

Thank you for reporting this comment. Undo
tropicallvr(11)

Hopefully your not overwatering, but if the soil is getting warm enough then it should just be a matter of time. I planted one from the supermarket(taro), and it took quite a while to sprout even though it was on a heat mat.

    Bookmark   May 23, 2007 at 6:20PM
Thank you for reporting this comment. Undo
xerophyte_nyc(7)

They need consistent warmth (60-70F soil temp) for about 4-5 weeks to sprout, so either it isn't warm enough, or you overwatered since they do not need water to sprout; wet soil can easily lead to rot in Colocasia tubers.

Carefully dig around and take a peek.

    Bookmark   May 25, 2007 at 8:02PM
Sign Up to comment
More Discussions
jubaea chilensis
Hi all. This is my first posting on this site and I'm...
palmvirgin
Crossandra, anyone?
This subforum is a pretty quiet place it seems. Nevertheless,...
wisconsitom
Passionflower in Washington?
Hi guys, do any of you have experience growing passionflowers...
Brandon_the_Random
Growing a tropical plum in Zone 5
I bought and planted a Golden plum tree I bought locally....
Weylynn
Tropical vine for part shade?
Hi all, I am looking for suggestions for a tropical...
ravensfan52
© 2015 Houzz Inc. Houzz® The new way to design your home™