What happened to my wisteria?

lisa2004(NY Z5/6)April 17, 2012

I have a large wisteria that I planted about 5 years ago. It has bloomed like crazy every year. It was completely covered with buds (either leaf buds or flower, can never remember which comes first). Today I noticed that all of the buds are dry and crispy. I broke off a piece of the vine and it is still green inside. This spring got warm very early, then we had a few days of cold temps. Not sure if it could have gotten hit by frost. I'm not too concerned about loosing a year of flowers, although it would be nice to see some bloom. I'm much more worried about the vine being OK. Any ideas? Thanks, Lisa

Thank you for reporting this comment. Undo
woodyoak zone 5 Canada(5b)

Almost certainly a frost... The vine should be fine if its still got wood showing green.

    Bookmark   April 17, 2012 at 9:59AM
Sign Up to comment
More Discussions
Pruning Solanum jasminoides ( Potato vine )
Does anyone know how far back I can trim my potato...
chiquitajuanita
Best Evergreen Vine
I am looking for a fast growing vine that will retain...
dandkmom
Best permanent indoor hanging vines?
Hello vine forum, Looking for some aesthetically pleasing...
gribbleton
Best evergreen (in zone 6b) vine to cover fence?
Hi, I'm new here. We bought a house late last summer,...
HollyAnnM
Fast growing shade vine for window box?
Hi there! I have 3 windows in my apartment that directly...
gwl2051
© 2015 Houzz Inc. Houzz® The new way to design your home™