My poor Morning Glory

xenofenix(La/ Zone 9)June 1, 2008

I don't know why, but I feel that there is something wrong with my Morning Glory. They are vining smoothly and all, but something seems wrong. Every vine has about 1 bloom per plant, and I have about 6, which are very large now. They are atleast a few feet in length, and I have NEVER even gotten them to create seeds. Plus, some are red looking and others are big green and fuzzy. Some leaves are small and others are large in certain areas. They are getting 2:00pm - 7:00pm sun. Am I doing something wrong? I water every other day.

Thank you for reporting this comment. Undo
ron_convolvulaceae

Hi xenofenix - Could you post(or send me) photos of what different types that you have so I could provide some relevant feedback...

Thanks(!)

Ron

Here is a link that might be useful: Ipomoea species with photos in the PlantFiles

    Bookmark   June 2, 2008 at 7:08PM
Sign Up to comment
More Discussions
Fast Growing Vines
Hey everyone! I would like to get some fast growing...
Matt Conner
Pruning
Need to do a hard prune on my hybrid honeysuckle vine....can...
Pam Merrill
Will disturbing roots inhibit flowering of Confederate Jasmine ?
I have a large confederate jasmine (trachelospermum...
peterk312
Creeping Fig Question
I'm wanting to grow creeping fig up the wall of a two...
Sow_what? Southern California Inland
Getting hops and honeysuckles to climb tall smooth posts?
I've got some vigorous hops vine, and so far less big...
fireweed22
© 2015 Houzz Inc. Houzz® The new way to design your home™