Moonflower not blooming at all :(

herbivoreAugust 5, 2007

My moonflower vine has grown and climbed very well (I grew it from seed) but after the flower buds developed, they are starting to shrivel up and turn hard and brown.

It is getting appropriate light and water. Help!

Thank you for reporting this comment. Undo
skippy05(z7 PA)

It sounds like it is going right to seed.
Maybe too much water, too much fertilizer??

    Bookmark   August 6, 2007 at 8:03PM
Thank you for reporting this comment. Undo
oxmyx(6)

It is not unusual for the early buds to shuck off due to extra rain or nutrient uptake. Give it a bit of time, I live in zone 6 and mine are just now forming buds, some have shucked off.

I have had trouble in past years, since it seams the plants look so unhealth for so long I felt I needed to feed them - Big Mistake!. Give them no food, or water lest you want rampant growth, at the expense of flowers.

I find Moonflowers take a while to take off and get those nice large leaves and finally flower.

    Bookmark   August 8, 2007 at 4:46PM
Sign Up to comment
More Discussions
Sweet Autumn Clematis on Ornamental Wire Trellis
My neighbors utility vehicles are parked right up to...
florananny
Are old MG seeds still good
I have some Japanese morning glory seeds that are several...
eloise_ca
Cascading Vine for Window Planter?
I recently moved out of a house with ample yard space...
SwampSlug
Best Evergreen Vine
I am looking for a fast growing vine that will retain...
dandkmom
Vigna Carracella seeds.
Have seeds available for Vigna Carracella. (Snail...
barry2008
© 2015 Houzz Inc. Houzz® The new way to design your home™