Return to the Adenium Forum | Post a Follow-Up

 o
Flower....finally

Posted by ladylotus Z3/4 ND (My Page) on
Tue, Aug 5, 14 at 21:52

I finally had a flower this weekend. However, I was not able to get a photo until this evening. I do not know the name as it is one of the first grafts I performed from a friend in Ohio's adeniums.

I should have many more blooms in the next couple weeks.


Follow-Up Postings:

 o
RE: Flower....finally

Here is another photo.


 o
RE: Flower....finally

Wow...that is beautiful bloom
Marie


 o
RE: Flower....finally

Beautiful!

Kirk


 o
RE: Flower....finally

Congrats on the bloom and the graft.
Beautiful and what a treat for you also.
Rick


 o
RE: Flower....finally

Very nice!!!

Lonnie


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Adenium Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here