Return to the Adenium Forum | Post a Follow-Up

 o
November adenium (Triple Splash)

Posted by ltran54 9 (My Page) on
Thu, Nov 8, 12 at 13:27

This is November, many of my plants still in bloom, but not freshly looking since the weather chances from cold to hot and to cold again.
My Triple Splash adenium still has 13 blooms and some buds.
It was better looking blooms from May-June, but still not bad looking in November.

These pictures took last night at 9:46 pm

Photobucket

Photobucket

Photobucket

Photobucket

Photobucket


Follow-Up Postings:

 o
RE: November adenium (Triple Splash)

Wow! Looks great. My generic pink one still has a few blooms. And I'm amazed my orchid tree is busting out in a lot of blooms. Crazy Texas weather confusing all the plants. LOL

Kirk


 o
RE: November adenium (Triple Splash)

Another beautiful DR. You really do have some gorgeous plants. The only one of mine that's still blooming is surprisingly in the coldest spot. It's in the GH with no supplemental lighting and nighttime temps in the 50's. Most of the others that I brought inside are going dormant.


 o
RE: November adenium (Triple Splash)

OMG! They are beautiful. love it!
My adult DR is giving it one last shot. :)


 o
RE: November adenium (Triple Splash)

bloom close up


 o
RE: November adenium (Triple Splash)

Simply beautiful...

Love all of the pics!!

Marie.. you have the most beautiful trees..

Laura


 o
RE: November adenium (Triple Splash)

Marie, as always great blooms! Thanks for sharing.
Mine are in bad shape this year :(. I pruned after first blooms faded, and plants newer really put out new growth. We got so much rain this summer that beeing in the soil-less mix, they just weren't getting enough nutrients, all was washing away. I'm surprised that only really small plants got "cooked" in very hot and wet gritty mix, large ones have healthy caudexes so there is hope for next year blooms. :o) This was first attempt to prune DR and I don't think I will do it again...

Aggie


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Adenium Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here