Return to the African Violets Forum | Post a Follow-Up

 o
No color on blooms

Posted by becky15349 5 (My Page) on
Thu, Feb 13, 14 at 14:01

Hi guys! I just have a question. I have a few avs that are reblooming, and they are dark purple avs, one dark pink, one splashy purple...except now they are reblooming with white blooms, very crinkled blooms that look sad and veery little show of any colors on the petals. All of them are doing this, which makes me think that I am giving them too much light. What do you think? I grow in a windowsill, but they are shaded well...


Follow-Up Postings:

 o
RE: No color on blooms

Becky,

How cold is your windowsill? I'm in zone 6b and the cold has been severe. You're in zone 5 so I know yours is as bad or worse.

Linda


 o
RE: No color on blooms

They may be receiving too much light and nighttime temps as Linda mentioned maybe too cold.

Cooks.


 o
RE: No color on blooms

I think you guys may be right. They are on racks a southern facing window so, but it does get cold at night. They are also well shaded it just seemed so bright no matter what I do. The only window exposure I have in my house is south facing. It's so frustrating! I am thinking of just getting a small desk lamp set up up. I don't have the space for fluorescent bulbs.thank you for your help


 o
RE: No color on blooms

Becky,

Try moving your plants at night as long as we continue to have this cold weather. Put them back in the daytime and then watch to see how they do. Your south facing window should not be a problem as long as they are shaded (and not too hot) in the summer. During the winter this exposure may be warmer than others which is good. Window grown violets generally will take as much light (not sun) as you can give them.

I think your problem is the weather. Hopefully, it will warm up soon!

Linda

As I drive home from Louisville in a snowstorm, on ice-covered roads, with stranded cars everywhere.

This post was edited by whitelacey on Sun, Feb 16, 14 at 2:56


 o
RE: No color on blooms

Linda
Hope you get home safely and are warm again
Joanne


 o
RE: No color on blooms

Joanne,

Thanks! We made it home safely but it was a slow go! Came home to 8 more inches of snow and it's snowing again. It's a good thing I have my orchids and violets to see me through this mess!

Linda


 o
RE: No color on blooms

Yes, glad you are back with your orchids and violets.
Joanne


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the African Violets Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here