Return to the African Violets Forum | Post a Follow-Up

 o
Blooming but dries before opens

Posted by gardencraze 9b Groveland FL. (cmmcginnis49@gmail.com) on
Wed, Jul 9, 14 at 14:08

Hi everyone, my AV is blooming loads but the blooms die and dry up before they open. Very new at growing AVs


Follow-Up Postings:

 o
RE: Blooming but dries before opens

Hi
This will happen if you let your AV soil dry after the buds start to form. Not soaking wet, but keep damp.
Cork


 o
RE: Blooming but dries before opens

Sometimes that happens for a bit after moving it from the greenhouse into your home. Put it inside a jar or bowl, something to raise the humidity around the plant.


 o
RE: Blooming but dries before opens

Low humidity can sometimes cause bud blast. As mentioned, put in a bowl or on rocks that have water in them. Do not let your violet sit in water but above it.

Linda


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the African Violets Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here