Return to the African Violets Forum | Post a Follow-Up

 o
What's wrong with my AV ?

Posted by momiji none (My Page) on
Sun, Oct 13, 13 at 11:25

Can anyone tell me what's wrong with my AV,
the edge of the leaves is constantly turning black ,
I have tried to cut off the black edge but few days later
The black edge is coming back .

Please tell me what to do .
Thanks


Follow-Up Postings:

 o
RE: What's wrong with my AV ?

Check to see if your water source contains chloramines.

If it does, you need to find another source of wa t er for your violets.


 o
RE: What's wrong with my AV ?

Wow, thanks, Aegis! I have a couple that has happened
to also. I read on this forum not to use water
with chloramines, so I have stopped.
Also, thanks for your advice on another thread
on gift-giving Optimaras. (That was my "instinct.")
I also appreciated the advice given by "brag"
on leaves.
Joanne


 o
RE: What's wrong with my AV ?

... This post was edited by bragu on Sun, Oct 20

This post was edited by bragu on Sun, Oct 20, 13 at 21:48


 o
RE: What's wrong with my AV ?

Your plant is sitting in too big of a pot and probably getting waterlogged. Need to move to a smaller pot - 1/3 of the crown diameter - and make sure that the soil has plenty of perlite to be well aerated.

Good Luck

iirna


 o
RE: What's wrong with my AV ?

Hi Dave,
Oops, s'cuse the typo--
I noticed that the header for the home
page of this forum includes
a recipe for Annie's Salsa. (Not sure if it shows up
only on the page I access or if it is on everyone's page.)
You wrote:
"that's .... bragu ....
i make salsa, with everything except the kitchen sink ... and got the moniker from my amigos decades ago ...

bragu it's in there ..."


 o
RE: What's wrong with my AV ?

I had that problem too and lost alot of plants. Sent a plant showing symptoms to UT Ag. Extension office and was told it was pythium. Had too much water in soil mix and this encouraged the fungus. Changed soil mix and things have been fine. If you can save a leaf do it now. That fungus ( a root rot) travels fast


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the African Violets Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here