Return to the African Violets Forum | Post a Follow-Up

 o
bugs!!

Posted by blossom_girl NS Canada (My Page) on
Sun, Oct 21, 07 at 17:45

I bought two new AVs yesterday (because I couldn't chose between them) and on the way home I noticed that one of them, and possible both, has BUGS! They're very small, kind of long and thin and I guess brownish and they were crawling around on one of the flowers. From that bad description can anyone tell me what they are or how to get rid of them?


Follow-Up Postings:

 o
RE: bugs!!

Kind of sounds like thrips..I have noticed lately at every store I have been in here in Seattle are selling violets with thrips..I tell them and they go "oh really"..I treat them by takeing off all the blossoms(and keeping them disbudded for a couple months) and sprinkleing systemic in the soil.Then I spray with a safer product for killing thrips..:0)..good luck...marigene


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the African Violets Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here