Return to the Amaryllis/Hippeastrum Forum | Post a Follow-Up

 o
Is This Normal...

Posted by puglvr1 9a central FL (My Page) on
Fri, Mar 25, 11 at 15:58

I don't know much about Amaryllis and don't know much about them.

I got this orange amaryllis two years ago from a friend and planted it...but it didn't bloom the second year. This year it bloomed...but look at the color...is this normal for Amaryllis? To start out orange and change colors the next time it blooms? Does it have something to do with a missing nutriet...I have another orange one planted in a different location...it has a bud but hasn't opened yet...I'll be curious to see what color this one turns out.

Thanks!


Follow-Up Postings:

 o
RE: Is This Normal...

Well, I had a red one last year that this year bloomed decidedly orange, but I've never seen one that totally changed it's stripes..so to speak..! It's still very pretty though...will be interesting to see if all your flowers on this particular bulb look like the one above..

Donna


 o
RE: Is This Normal...

  • Posted by haweha 7/Germany/W (My Page) on
    Fri, Mar 25, 11 at 19:54

I guess that you received a whole cluster of Knight Star Lilies together in one container. The scape that would emerge THIS season, is simply from another bulb, and another hybrid, individual, clone, you name it, respectively. It is a heirloom hybrid, and it is not looking that bad at all! Is it fragrant?


 o
RE: Is This Normal...

Nancy, I don't know much about Amaryllis either, but I know one thing: I love your bloom :-)

Welcome to the forum.

Xuan


 o
RE: Is This Normal...

Thanks everyone!! Appreciate the nice comments and explanation. My other plant should bloom orange I'm pretty sure because that one I purchased as a "single" bulb. I'll post a picture of that one when it opens.

It has a weak scent...so I wouldn't say its fragrant. It is pretty though! Hopefully, I'll get another bloom and a different color too.

Hi Xuan, nice to see you too!!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Amaryllis/Hippeastrum Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here