Return to the Aquariums Forum | Post a Follow-Up

 o
My fish died. Why?

Posted by chillie1011 77388 (My Page) on
Sun, Oct 16, 05 at 16:45

I got new fish at Walmart and one, after about a week or two died. One of them, lost there color after I found them dead. The other one, was found in a white sac. Please help!

Additional information: ten gallon tank with top fin filter. One molly, two red tailed tetras, three black shirt tetras, and a small pleco. I tested my water and every thing is fine.

Thanks, I hope you can help!


Follow-Up Postings:

 o
RE: My fish died. Why?

Is this a new tank? What are your test results, particularly Ammonia and Nitrite ? Are the 2 fish new, or are they all new? What kind of Pleco? I don't understand ""found in a white sac."?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Aquariums Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here