Return to the Aroid Forum | Post a Follow-Up

 o
arisaema sikokianum bloom mush?

Posted by buturfliis_mom z5chicago (My Page) on
Wed, Jun 15, 11 at 11:32

My Arisaema sikokianum bloomed for the first time this year. After about three weeks of this gorgeous bloom, the white bulbous part and the "hood" turned into mush and fell off. This happened to all of the three plants that had bloomed. The green leaves still look fine...

Should I expect seed?
Is this normal, are the plants okay?


Follow-Up Postings:

 o
RE: arisaema sikokianum bloom mush?

The spathes of many aroids fall off once the plant is done blooming. It isnt necessarily a sign of successful pollination, but it could be. Wait and see if little seeds start to grow at the spadix that is left.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Aroid Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here