Return to the Aroid Forum | Post a Follow-Up

 o
Calla not flowering

Posted by shinysun UK (My Page) on
Tue, Jul 1, 08 at 6:03

I got given a Calla which was in bloom in May 2006. It has always been kept indoors, let it go dormant, and brought it out in the spring. The leaves grew great but it never flowered. Same thing happened this year - lots of leaves but no flowers!

Any ideas on what I'm doing wrong? I have watered it with added generic houseplant feed, but that is all.

Any advice much appreciated!


Follow-Up Postings:

 o
RE: Calla not flowering

do you know what color it is? Some like the yellow calla the bulbs has to be big. Also is it in a pot or in the ground they seem to flower better in the ground it also could be a late bloomer there are many reasons. I know I had one year where most of mine did not flower. Anna


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Aroid Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here