Return to the Aroid Forum | Post a Follow-Up

 o
Zantedeschia

Posted by tindomul1of9 (My Page) on
Tue, Jul 17, 07 at 16:25

Hi all,

I have a Zantedeschia sp. that I bought from the supermarket in April 2006.
It was in flower all spring and summer. Became dormant in the fall and I replanted it this April. The corms have produced healthy large leaves, but no flowers. Is there something missing? Am I not keeping it wet enough?
Also, when I bought it, the leaves were darker and more heart shapped. Now they are a pretty lighter green and lance shapped. Whats going on? Thanks.

Here is a link that might be useful: This years growth


Follow-Up Postings:

 o
RE: Zantedeschia

and here is last years growth

Here is a link that might be useful: last year's growth


 o
RE: Zantedeschia

I am not an expert. The plant looks like it is stretching for light. Are you trying to grow it inside as a houseplant? I have always grown mine outside and have had a hard time getting them to flower unless I gave them a lot of fertilizer and sunlight. (They may be a shade plant in Texas but they need sun in my cold zone.) Started giving them Bloom Booster in April and continue all summer. I gave them the ferts every two weeks.

I do not know if this is bad or not but it was the only way I could get them to bloom after looking at leaves all summer for two years.


 o
RE: Zantedeschia

Not enough light. Zantedeschia like full sun.


 o
RE: Zantedeschia

Thanks for the advice.
I really didn't know these guys had to be outside. They do get plenty of orchid fertilizer and lots of hot morning sun during the summer months. But I have no place for them outdoors. Thanks!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Aroid Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here