Return to the Azalea & Rhododendron Forum | Post a Follow-Up

 o
Azalea Anchorite - Evergreen?

Posted by pacnwjudy z8 OR (My Page) on
Wed, Apr 18, 07 at 2:10

I live in Portland, Oregon, zone 8. A few years ago I got the azalea Anchorite and each winter it's been losing all its leaves and then more or less growing more of them, although not in such a lush way as when I got the plant. And each year it's blooming like you wouldn't believe, each year more fabulous than the last.

I have many evergreen azaleas, and Anchorite is supposed to be one of those. I've never had one lose its leaves except Anchorite. I wonder what gives.


Follow-Up Postings:

 o
RE: Azalea Anchorite - Evergreen?

Some of the evergreen Glenn Dale Azaleas naturally drop leaves during colder weather. Anchorite is one such example so do not worry.

Luis


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Azalea & Rhododendron Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here