Return to the Azalea & Rhododendron Forum | Post a Follow-Up

 o
Yellow leaves, little bloom

Posted by shelleyh z5 NY (My Page) on
Sun, Apr 28, 13 at 8:05

My 2 Rhodies are in part sun and are around 7 years old. I had to cut one back 4 years ago because a limb fell on it. It still has only one flower bud on it. The other one has only 4 buds on it and some of the leaves on both are either yellow with brown edges or just plain yellow. Should I fertilize them to get more buds and what do yellow leaves mean?


Follow-Up Postings:

 o
RE: Yellow leaves, little bloom

There are a number of causes for yellow leaves, nearly all of which are related to problems with the soil/roots: soil pH, too wet, too dry, overly compacted, etc. etc. The first step would be a soil test before doing any sort of fertilizing.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Azalea & Rhododendron Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here