Return to the Azalea & Rhododendron Forum | Post a Follow-Up

 o
why doesnt my rhododendron bloom?

Posted by trishalove 7b VA (My Page) on
Mon, Apr 20, 09 at 10:31

I planted a rhododendron that was in full bloom at the time, 2 seasons ago. It didnt bloom or set buds last spring and no buds this spring. It is very green and healthy.

Is there anything I can do to get it to bloom?

Thanks!


Follow-Up Postings:

 o
RE: why doesnt my rhododendron bloom?

  • Posted by morz8 Z8 Wa coast (My Page) on
    Mon, Apr 20, 09 at 12:20

It isn't unusual for a recently planted rhododendron to skip a season or two of producing flower buds while becoming established in your garden - this tendency will vary somewhat according to variety. It could be establishing roots and framework in lieu of flowers...

Other reasons for failure to bloom are too much shade, over fertilization, and drought in late summer when buds are normally set. Also pruning at wrong time of year, but I suspect you haven't pruned such a young shrub :)


 o
RE: why doesnt my rhododendron bloom?

Thanks for you response. It's the typical purple rhododendron...don't remember the variety. No I havent pruned it or fertilized it. It's possible it wasnt watered enough end of last summer...but youre probably right, it's probably establishing roots. I'll patiently wait another year with fingers crossed!


 o
RE: why doesnt my rhododendron bloom?

Is it getting enough sun?


 o
RE: why doesnt my rhododendron bloom?

my Azaleas were beautiful as usual except one. It has bloomed for years but suddenly this spring and last no blooms? It appears healthy , it is growing around four others that bloomed beautiful, Any one have any advice? Thank you


 o
RE: why doesnt my rhododendron bloom?

Sometimes the trees around azaleas grow to the point that the light decreases.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Azalea & Rhododendron Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here