Return to the Azalea & Rhododendron Forum | Post a Follow-Up

 o
fertlizer burn

Posted by bunster z6IN (My Page) on
Sun, Apr 19, 09 at 15:17

I have a couple of 'Elsie Lee' azaleas purchased last year that have been healthy until recently when I noticed what looks to me to be fertilizer burn. Both plants are covered with buds (just ready to open) that look like they might be affected somewhat? hard to tell-anyway, if this is the case with the burn, will these buds still open and flower? Also, is there anything I can do to alleviate the problem? Thanks!!!


Follow-Up Postings:

 o
RE: fertlizer burn

This time of year winter burn and fertilizer burn look similar except winter burn is on the sunny side and fertilizer burn is uniform over the entire plant. In either case you should be OK. Azaleas don't need much if any fertilizer unless they show specific symptoms of problems.

Here is a link that might be useful: How to grow azaleas.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Azalea & Rhododendron Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here