Return to the Azalea & Rhododendron Forum | Post a Follow-Up

 o
azalea petal blight

Posted by ehendry91 none (My Page) on
Sun, May 5, 13 at 9:27

Hi I recently purchased a small indoor Azalea. It mostly seems very healthy with new leaves growing but some of the buds and petals are turning slightly brown particularly around the edges and with speckles through the middle. Is this normal? I was wondering if too much sunlight could cause this or is it perhaps petal blight? Thanks.


Follow-Up Postings:

 o
RE: azalea petal blight

Most likely came from a greenhouse w/ perfect conditions. Now, not so much.

What has your humidity been?
Perhaps dry petal edges due to low humidity? Or the dry air of a heated indoor environment?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Azalea & Rhododendron Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here