Return to the Azalea & Rhododendron Forum | Post a Follow-Up

 o
Azalea browning

Posted by genesis1 6.5 (My Page) on
Thu, May 2, 13 at 21:08

I planted an azalea late last season (August or so) in a spot near where many others grow vigorously. I watered it well the first few weeks or so and then left it. I just noticed now that its leaves are browning. I easily pulled it up (had really no root growth since planting) , added some good soil, watered and fed it (Holly tone). Just wondering if its worth it to continue nursing it (is there hope??), or should I just pull and replace? It was the last azalea i planted last year so I think I may not have watered it enough. I


Follow-Up Postings:

 o
RE: Azalea browning

Probably never rooted in.
Any chance of posting images?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Azalea & Rhododendron Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here