Return to the Azalea & Rhododendron Forum | Post a Follow-Up

 o
azalea dying, please help!

Posted by jeffyt PA (My Page) on
Fri, Sep 26, 08 at 14:17

not sure of the exact type, but I have a large pink azalea which has white spots all over the leaves on new growth then they turn brown and the backs of leaves have rust colored specks all over them. Please help me.


Follow-Up Postings:

 o
RE: azalea dying, please help!

  • Posted by morz8 Z8 Wa coast (My Page) on
    Sat, Sep 27, 08 at 13:06

It's hard to be sure without a photo, but while azaleas do get rust, I suspect you are seeing lace bug damage. Why don't you do an image search and compare to the symptoms your plant is exhibiting....

Let us know if that isn't it, we'll go from there.

Here is a link that might be useful: UC Davis Pest Notes - Lace Bug


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Azalea & Rhododendron Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here