Return to the Arizona Gardening Forum | Post a Follow-Up

 o
Plumeless Apache Plume?

Posted by Juttah Tucson (My Page) on
Tue, Sep 17, 13 at 14:03

I have an Apache Plume (fallugia paradoxa) that I planted a year ago in full sun.

It's very healthy and has quadrupled in size. Bloomed in late spring and again with the monsoon rains -- at the moment it's got at least 3 dozen white flowers.

Only problem is, it has yet to produce a single "plume"! I do see bees and other insects pollinating it, although it doesn't seem to attract as many pollinators as some of my other natives. Any idea what's going on?


Follow-Up Postings:

 o
RE: Plumeless Apache Plume?

don't the plumes come after the flowers?


 o
RE: Plumeless Apache Plume?

They should .... but it's been flowering on and off since March. Surely it doesn't take over 6 months to go from flower to plume?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Arizona Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here