Return to the Banana Forum | Post a Follow-Up

 o
new pups

Posted by fishoifc 8 (My Page) on
Thu, May 29, 08 at 13:15

ordered some new plants about three weeks ago put them in ground and they look the same. no growth has started yet there just sitting ther with the same leave half way open any suggestions


Follow-Up Postings:

 o
RE: new pups

in a zone 8 you should be getting some heat now. growth is predicated on sun, heat, more heat and fertilizer. try puting some 1/2 strength fertilizer on your bananas. If they are in the sun, your temps in the 80's and fertilized properly you should see growth within just a few days. good luck. Bananas when actively growing need lots of water too.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Banana Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here