Return to the Begonia Forum | Post a Follow-Up

 o
begonia help

Posted by raylynn2 8a (pmaynard69@gmail.com) on
Wed, Jul 31, 13 at 11:30

I received a box last night and everything in it was fine except the begonia :( it is limp and almost gushy like it got to cold but I know that was not the case so it must have got to hot. Is there any fixing it I planted it in good soil and watered good so now should I leave it be our should I cut it off and try to get it to come back. Any help would be fearful thanks so much


Follow-Up Postings:

 o
RE: begonia help

Gee, it sounds like a mess. I think you should report it right away if it is a plant you ordered and paid for. There is a chance, I think, if it is not too hot outdoors you could put some kind of plastic protection tightly over it to help hold the humidity even though it sounds like it has already started to turn to mush.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Begonia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here