Return to the Begonia Forum | Post a Follow-Up

 o
Begonia going limp, help!

Posted by valthewizard 5 (My Page) on
Sat, Aug 31, 13 at 15:02

I have 3 decent sized begonia plants. Each was doing very well and blooming constantly, then after awhile their stems became very limp. I don't think I'm overwatering.

Do they need cut back or something? I can't figure out why they are suddenly going bad.

What should I do?


Follow-Up Postings:

 o
RE: Begonia going limp, help!

What kind of begonias do you have? Are they inside or outside? What are the temps like where they reside? Do you allow them to dry some between watering? Have you checked for rot near the base of the plants? Is the soil soggy or dried out?

A picture is worth a thousand words if you can post one. It helps determine what kind of plant, what the pot looks like compared to the plant, how the soil looks, how the wilt looks, etc.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Begonia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here