Return to the Bromeliad Forum | Post a Follow-Up

 o
Mouldy Guzmania blooms

Posted by phee78 (My Page) on
Sun, Mar 3, 13 at 2:04

I recently got a Guzmania, don't know its exact name, but it's got an orangey red inflorescence. I just noticed that the little buds at the top of the inflorescence are covered in mould. Pulling back some of the bracts further down, I noticed a bit of mould in there too.

It's not the usual dying off of a brom flower, it's like when a loaf of bread goes mouldy and you get furry stuff growing on it. Anyone ever experienced this before, or have any idea what I could do to fix it?

This post was edited by phee78 on Sun, Mar 3, 13 at 2:05


Follow-Up Postings:

 o
RE: Mouldy Guzmania blooms

I have found this with my Aechmeas. It seems to be the flower and so far has not gotten into the berry. We'll see. It probably comes from the humidity level.


 o
RE: Mouldy Guzmania blooms

air circulation is to low


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Bromeliad Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here