Return to the Bromeliad Forum | Post a Follow-Up

 o
*** vriesea splendens help!!! ****

Posted by erik76 ireland (My Page) on
Thu, Nov 15, 12 at 16:52

HI. Hope someone can help with a (hopefully !! :) ) simply question ? :

have had the plant in question for several months now... have not fertilised it, have watered through 'tank' only ... the brown/dark brown patches/marks pictured worry me ! - any suggestions as to what they are/might be ? -- or , better still , am i worrying about absolutely nothing !!? :)

help appreciated :)


Follow-Up Postings:

 o
RE: *** vriesea splendens help!!! ****

Looks normal for a Vriesea to me.


 o
RE: *** vriesea splendens help!!! ****

good !!- thanks fo the reply :) it looks/seems 'healthy' otherwise .... just worried a wee bit .

thanks again!

erik�


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Bromeliad Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here